PHP-SAFE Startseite

Willkommen auf der Webseite von PHP-SAFE

13. Juli 2008 von Thomas Wacker

Alpha-Version 0.3 verfügbar

18. Juni 2008 von Thomas Wacker

PHP-SAFE (PHP Simple Application Firewall Extension) ist eine native PHP-Erweiterung (reines PHP, keine .dll oder .so erforderlich), die ohne großen Installationsaufwand einherkommt.

PHP-SAFE wendet sich an Webmaster, die nicht die Zeit oder die Kenntnisse haben, ältere PHP-Anwendungen zu modernisieren, oder komplexe Lösungen wie mod_security nicht einsetzen können.

PHP-SAFE ist kein Ersatz für etablierte Systeme wie Suhosin oder mod_security, sondern vielmehr als nützliche Ergängzung gedacht. Da PHP-SAFE komplett in PHP geschrieben ist, sollte es auch mit den vorgenannten Sicherheitserweiterungen keine Probleme geben.

PHP-SAFE erhebt keinerlei Anspruch auf Vollständigkeit. Jeder der bei Betreten dieser Seite denkt, dass PHP-SAFE alle Sicherheitsprobleme seiner Anwendung löst, sollte sich besser genauer informieren!